ГлавнаяКарта сайтаНапишите намПоиск по сайту
EDS-Soft
ElectroDynamic Systems Software ScientificTM
Antenna Systems ResearchTM
Radiolocation Systems ResearchTM






Линзовая антенна

Антенна, процессы в которой основаны на том, что материалы (диэлектрики и металлы), из которых изготавливается так называемая …

(из «Словаря терминов» нашего сайта)






Документация по RefereesHelp Race™



RefereesHelp Race является профессиональным решением по учету данных о проведении соревнований по бегу, плаванию или лыжным гонкам. RefereesHelp Race поможет в оформлении участников соревнований и позволит легко и быстро получить информацию о результатах проведенных соревнований, создать и распечатать протоколы и результаты соревнований.



Главное окно

Главное окно разделено на несколько областей:

«Главное меню» — подробное описание см. в разделе «Главное меню».
«Панель инструментов» — подробное описание см. в разделе «Панель инструментов».
«Боковая панель» — предназначена для отображения статистической информации по количеству участников из каждого населенного пункта и по каждой дистанции.
«Строка состояния» — предназначена для отображения информации о текущих дате и времени, текущей открытой таблицы и статусе программы.
«Область отображения таблиц» — предназначена для отображения таблиц с данными.


Главное меню

Главное меню программы содержит следующие пункты: «Файл», «Вид», «Дистанции», «Участники», «Статистика», «Настройки», «Помощь».


Меню «Файл»

«Настройка печати» — вызов диалогового окна настройки печати.
«Предпросмотр» — предварительный просмотр документа перед отправкой на печать.
«Печать протоколов» — печать текущего протокола, всех стартовых или всех финишных протоколов.
«Выход» — закрытие программы.


Меню «Вид»

«Дизайнер» — вызов дизайнера протоколов.
«Язык» — выбор языка интерфейса программы.
«Стиль» — выбор и смена стиля оформления.
«Панели инструментов» — скрытие и отображение панелей инструментов.
«Боковая панель» — отображение или скрытие статистической информации на боковой панели.
«Строка состояние» — скрытие и отображение строки состояния.


Меню «Дистанции»

Данное меню предназначено для вызова диалоговых окон ввода информации о новых участниках, редактирования информации об участниках, ввода результатов соревнований, редактирования уже существующих данных, просмотра стартового или финишного протоколов, листов награждения или просмотра всей базы данных по каждой дистанции.

Каждый пункт меню представляет собой длину каждой дистанции в базе данных и имеет следующие подпункты:

«Новые участники» — отображение диалогового окна добавления нового участника.
«Результаты» — отображение диалогового окна ввода результатов соревнования для участника.
«Редактирование данных» — отображение диалогового окна редактирования информации об участнике.
«Вывод информации» — просмотр данных об участниках, включенных в стартовый, финишный протоколы или наградной лист по каждому полу.
«Просмотр базы данных» — просмотр данных об участниках дистанции.


Меню «Участники»

«Возрастные группы» — вызов диалогового окна с информацией об участниках по возрастным группам и дистанциям.
«Поиск…» — вызов диалогового окна поиска информации об участниках соревнований.
«Самые молодые и старейшие» — отображение информации о самых молодых и старейших участниках соревнований по всем дистанциям.


Меню «Статистика»

«Наилучшие результаты» — вызов диалогового окна поиска рекордных результатов по каждой дистанции.


Меню «Настройки»

«Текущий год» — установка года проведения соревнований.
«Перемещение таблиц» — вызов диалогового окна импорта данных из внешних файлов баз данных.
«Внешний редактор» — вызов редактора базы данных.
«Обновить отображение» — импорт данных из текстовых файлов базы данных.
«Конфигурация…» — вызов диалогового окна параметров конфигурации программы.


Меню «Помощь»

«Помощь» — вызов справки программы.
«Что нового?» — вызов диалогового окна с информацией о том, что нового появилось в текущей версии программы и список изменений в предыдущих версиях.
«Ссылки в Интернет» — переход на сайт разработчиков программы, страницу программы или переход на страницу регистрации (покупки) программы.
«О программе» — вызов диалогового окна «О программе».


Панели инструментов

В главном окне программы представлены три панели инструментов, которые находятся под главным меню. На панелях инструментов находятся кнопки для вызова часто используемых функций. Каждая кнопка по своей функциональности соответствует определенному пункту меню. Использование панелей инструментов позволит сэкономить время, т.к. для вызова определенной функции достаточно щелкнуть по кнопке на панели инструментов.

На панели «Дистанции» расположен список для переключения между дистанциями и кнопки для работы с данными по выбранной дистанции: «Просмотр базы данных», «Редактирование данных», «Добавление нового участника», «Ввод результатов соревнований» и «Удаление базы данных». Данная панель инструментов аналогична меню «Дистанции» главного меню.

На Базовой панели представлены кнопки «Возрастные группы», «Поиск участников», «Конфигурация программы», «Запуск внешнего редактора баз данных» и «Синхронизация отображения с базами данных», которые аналогичны соответствующим пунктам главного меню.

На панели «Помощь» представлены кнопки «Помощь», «Что нового», «О программе». Данная панель инструментов аналогична меню «Помощь» главного меню.



Конфигурация

Установка параметров конфигурации программы и базы данных осуществляется в диалоговом окне «Конфигурация программы», которое может быть вызвано одним из следующих способов:

Вызовом пункта главного меню «Настройки\Конфигурация…».
Нажатием кнопки «Конфигурация программы» на панели инструментов.
Сочетанием клавиш Alt+S.
С помощью диалогового окна «Конфигурации программы» настраиваются следующие параметры:
Название соревнований (задается в поле ввода «Название соревнований»).
Список дистанций.
Список возрастных групп.
Колонки таблиц.
Список судей.
Параметры программы.
Параметры базы данных.

Список дистанций

Список дистанций расположен на вкладке «Дистанции» диалогового окна «Конфигурация программы».


Добавление дистанции

Для добавления дистанции необходимо:

Щелкнуть правой кнопкой мыши по списку дистанций.
В контекстном меню выбрать пункт «Добавить».
В появившемся диалоговом окне ввести длину дистанции и нажать кнопку «Применить».

Редактирование дистанции

Для редактирования дистанции необходимо:

Щелкнуть правой кнопкой мыши по дистанции в списке дистанций.
В контекстном меню выбрать пункт «Редактировать».
В появившемся диалоговом окне ввести длину дистанции и нажать кнопку «Применить».

Удаление дистанции

Для удаления дистанции необходимо:

Щелкнуть правой кнопкой мыши по дистанции в списке дистанций.
В контекстном меню выбрать пункт «Удалить».

Возрастные группы

Список возрастных групп расположен на вкладке «Возрастные группы» диалогового окна «Конфигурация программы», для каждой дистанции определяется свой список возрастных групп, для этого для каждой дистанции существует своя вкладка со списком возрастных групп, каждый список возрастных групп состоит из двух столбцов, определяющих половой признак участника (юноши/девушки, мужчины/женщины).


Добавление возрастной группы

Для добавления возрастной группы необходимо:

Щелкнуть правой кнопкой мыши списку возрастных групп.
В контекстном меню выбрать пункт «Добавить».
В появившемся диалоговом окне установить параметры добавляемой возрастной группы и нажать кнопку «Применить».

Редактирование возрастной группы

Для редактирования возрастной группы необходимо:

Щелкнуть правой кнопкой мыши по элементу списка в столбце того полового признака, параметры которого необходимо изменить.
В контекстном меню выбрать пункт «Редактировать».
В появившемся диалоговом окне установить параметры возрастной группы и нажать кнопку «Применить».

Удаление возрастной группы

Для удаления возрастной группы необходимо:

Щелкнуть правой кнопкой мыши элементу списка в столбце того полового признака, который необходимо удалить.
В контекстном меню выбрать пункт «Удалить».

Колонки таблиц

Для настройки отображения колонок таблиц необходимо перейти на вкладку «Колонки таблиц» диалогового окна «Конфигурация программы», на данной вкладке для каждой таблицы существует своя вкладка, где производится настройка отображения таблицы.


Редактирование параметров колонок таблиц

Каждая колонка таблицы имеет следующие параметры и элементы управления:

Галочка «Акт.» включает отображение столбца в таблице.
Поле ввода «Заголовок таблицы» определяет заголовок столбца таблицы.
Поле ввода «Ширина» определяет ширину столбца таблицы.
Ниспадающий список «Выравнивание» определяет выравнивание текста в столбце таблицы (Left — выравнивание по левому краю; Center — выравнивание по центру; Right — выравнивание по правому краю).
Галочка «Редакт.» включает возможность редактировать элемент столбца таблицы.
Ниспадающий список «Тип записи» определяет поле базы данных для данных в столбце таблицы.

Список судей

Список судей расположен на вкладке «Судьи» диалогового окна «Конфигурация программы».


Добавление судьи

Для добавления нового судьи необходимо:

Щелкнуть правой кнопкой мыши по полю со списком судей.
В контекстном меню выбрать пункт «Добавить».
В появившемся диалоговом окне ввести данные о должности судьи и его ФИО (в формате Фамилия И.О., например: Иванов И.И.) и нажать кнопку «Применить».

Изменение информации о судье

Для редактирования данных о судье необходимо:

Щелкнуть правой кнопкой мыши по строке с именем судьи в списке судей.
В контекстном меню выбрать пункт «Редактировать».
В появившемся диалоговом окне изменить данные о судье и нажать кнопку «Применить».

Удаление судьи

Для удаления судьи из списка судей, необходимо:

Щелкнуть правой кнопкой мыши по строке с именем судьи в списке судей.
В контекстном меню выбрать пункт «Удалить».

Параметры программы

Параметры программы задаются в диалоговом окне «Конфигурация программы» на вкладке «Служебная информация» — «Информация и параметры». Настройки сгруппированы по двум типам: «Параметры» и «Выводимая информация».

Тип «Параметры»:

Галочка «Использование ввода поля «Спортивное общество» («Команда»)» определяет, будет ли использоваться поле ввода «Спортивное общество» в диалоговых окнах добавления и редактирования.
«Ограничение минимальных размеров главного окна» определяет установить ограничение на минимальный допустимый размер главного окна. Если данный параметр включен, то при изменении размеров главного окна, оно не будет уменьшаться до определенных размеров.
«Подсказки (хинты) о возрастных группах (в трее)» определяет, будут ли отображаться подсказки о возрастных группах при наведении мыши на участников в левой панели (трее).
«Инструментальные панели (тулбары)» определяет, будут ли отображаться панели инструментов в главном окне.
Тип «Выводимая информация». Параметры в данной группе разрешают/запрещают использование и отображение таблиц «Базы данных», «Стартовый протокол», «Финишный протокол», «Наградной лист», «Самые молодые и старейшие участники», «Участники из выбранного населенного пункта». В случае, если таблица запрещена (галочка напротив названия таблицы не стоит), то не будут отображаться элементы управления (пункты главного меню и кнопки на панелях инструментов) для данной таблицы.

Параметры базы данных

Параметры базы данных задаются в диалоговом окне «Конфигурация программы» на вкладке «Служебная информация» — «База данных».


Настройки базы данных

Настройки базы данных имеют четыре группы:

«Тип базы данных» — установка формата базы данных. При изменении данного параметра будет произведена конвертация базы данных в новый формат.

«База данных» — путь к базе данных и название файла базы данных:

Поле ввода «Название» определяет название файла базы данных. Доступно только для баз данных формата AbsoluteDatabase.
Поле ввода «Относительный путь» определяет путь к базе данных относительно абсолютного пути. Доступно только для баз данных формата AbsoluteDatabase.
Поле ввода «Абсолютный путь» определяет абсолютный путь к базе данных. Данное поле ввода не предназначено для редактирования, для его изменения, необходимо нажать кнопку «Изменить абсолютный путь».
Кнопка «Изменить абсолютный путь» предназначена для указания абсолютного пути к базе данных.
Таким образом, путь к базе данных определяется в формате «Абсолютный путь», «Относительный путь», «Год проведения соревнования», «Название файла базы данных», например, если «Абсолютный путь» = C:\Program Files\RefereesHelp Race\, «Относительный путь» = data\, «Название» = Peoples.abs, то полный путь к базе данных будет C:\Program Files\RefereesHelp Race\data\«Год проведения соревнования»\Peoples.abs. Директория «Год проведения соревнования» создается для каждого года отдельно.
Примечание: изменение абсолютного пути к базе данных действительно только в течение текущего сеанса работы программы, при повторном запуске программы абсолютный путь к базе данных будет установлен в своё первоначальное значение.

«Конвертация базы данных» — кнопки в данной группе предназначены для сохранения базы данных текущего формата в базу данных другого формата в текущей папке с базой данных.

«Точность представления результатов» — определяет точность результатов, хранимых в базе данных: до целых секунд, до десятых долей секунд, до сотых долей секунд.



База данных: просмотр, добавление, удаление, редактирование, печать

Для просмотра базы данных по определенной дистанции необходимо:

В меню Дистанции выбрать дистанцию, для которой необходимо просмотреть базу данных и выбрать пункт «Просмотр базы данных».
или
На панели инструментов выбрать дистанцию, для которой необходимо просмотреть базу данных и нажать кнопку «Просмотр базы данных».
После этого в главном окне программы появится таблица с данными о каждом участнике соревнований по выбранной дистанции.

Для таблицы имеются следующие элементы управления:

Группа «Вывод на печать»: параметры и вид отчета и его печать.
Кнопка «Дизайнер»: запуск дизайнера отчетов для редактирования вида отчета.
Кнопка «Предпросмотр»: просмотр отчета перед печатью.
Кнопка «Печать»: печать отчета на текущем принтере (для настройки параметров печати, вызовите пункт меню «Файл» — «Настройка печати…»).
Галочка «Подписи судей»: указывает, будут ли отображаться в отчете подписи судей.
Кнопка «Закрыть таблицу»: закрытие текущей таблицы.
Для каждого из участников в данной таблице можно произвести следующие действия:
Добавить нового участника.
Изменить данные об участнике.
Удалить участника.
Для добавления нового участника, необходимо:
Щелкнуть правой кнопкой мыши по списку участников и в контекстном меню выбрать пункт «Добавить».
В появившемся диалоговом окне ввести стартовый номер участника и нажать кнопку «Enter» на клавиатуре, в случае, если участник с введенным стартовым номером уже существует, появится окно с сообщением «Такой стартовый номер уже существует».
Ввести данные об участнике соревнований: фамилию, имя, отчество участника (в формате Фамилия И.О., например: Иванов И.И.), его пол, год рождения, населенный пункт и спортивное общество, который он представляет, а затем:
Для сохранения информации об участнике нажать кнопку «Сохранить».
Для сохранения информации о введенном участнике и добавления нового участника соревнований нажать кнопку «Следующий», после чего откроется новое диалоговое окно ввода участника.
Для выхода из диалогового окна без сохранения данных об участнике, нажать кнопку «Выход».
Для редактирования данных об участнике, необходимо:
В списке участников щелкнуть правой кнопкой мыши по строке с данными участника и в контекстном меню выбрать пункт «Редактировать».
В появившемся диалоговом окне ввести данные об участнике соревнований: фамилию, имя, отчество участника (в формате Фамилия И.О., например: Иванов И.И.), его пол, год рождения, населенный пункт и спортивное общество, который он представляет, а затем:
Для сохранения информации об участнике нажать кнопку «Сохранить».
Для сохранения информации о введенном участнике и добавления нового участника соревнований нажать кнопку «Следующий», после чего откроется новое диалоговое окно ввода участника, где необходимо будет ввести стартовый номер участника, которого нужно отредактировать и нажать кнопку “Enter” на клавиатуре.
Для выхода из диалогового окна без сохранения данных об участнике, нажать кнопку «Выход».
Кроме того, имеется возможность отредактировать данные об участнике следующим способом:
Дважды щелкнуть левой кнопкой мыши по тому полю, которое необходимо отредактировать.
Отредактировать данные и нажать кнопку “Enter” на клавиатуре.
Для удаления участника, необходимо:
В списке участников щелкнуть правой кнопкой мыши по строке с данными участника и в контекстном меню выбрать пункт «Удалить».
В появившемся диалоговом окне нажать кнопку “Yes” для удаления участника или “No” для отмены процесса удаления.

Поиск данных

Для вызова диалогового окна поиска участников соревнований в базе данных, можно воспользоваться одним из следующих способов:

В меню Участники, выбрать пункт «Поиск…».
На панели инструментов нажать кнопку «Поиск по базам данных участников».
Нажать сочетание клавиш Alt+F на клавиатуре.
В окне поиска участников необходимо:
Установить флажок напротив тех критериев, по которым будет осуществляться поиск участников соревнований.
Установить год, в котором будет осуществляться поиск участников соревнований.
Ввести фразу, по которой будет осуществляться поиск участников соревнований.
После чего, необходимо нажать на кнопку «Начать поиск», расположенной после поля ввода поисковой фразы или нажать клавишу “Enter” на клавиатуре.

По завершении поиска, можно воспользоваться функцией предварительного просмотра или затем распечатать полученный результат, для этого в нижней части окна появится группа элементов «Вывод на печать», их назначение аналогично назначению элементов «Вывод на печать» в таблицах просмотра базы данных.



Добавление нового участника соревнований

Добавление информации о новом участнике соревнований осуществляется следующим образом:

В меню «Дистанции» выберите дистанцию, для которой необходимо добавить нового участника соревнований, далее в подменю «Ввод информации выберите пункт «Новые участники».
или
На панели инструментов выберете дистанцию, для которой необходимо добавить нового участника соревнований и нажмите кнопку «Добавление нового участника».
В появившемся диалоговом окне установите личные данные участника соревнований: стартовый номер, Фамилия, Имя, Отчество, Пол, год рождения, населенный пункт и спортивное общество, которое представляет участник, затем:
Для сохранения информации об участнике нажмите кнопку «Сохранить».
Для сохранения информации и ввода информации о следующем участнике соревнований нажмите кнопку «Следующий», после чего откроется новое диалоговое окно ввода участника.
Для выхода из диалогового окна без сохранения данных об участнике, нажмите кнопку «Выйти».

Редактирование информации об участнике соревнований

Редактирование информации об участнике соревнований осуществляется следующим образом:

В меню «Дистанции выберите дистанцию, для которой необходимо отредактировать участника соревнований, далее выберете пункт «Редактирование данных».
или
На панели инструментов выберете дистанцию, для которой необходимо отредактировать участника соревнований и нажмите кнопку «Редактирование данных».
В появившемся диалоговом окне введите стартовый номер участника и нажмите кнопку Enter, после чего в диалоговом окне отобразиться полная информация об участнике соревнований. Далее, отредактируйте данные об участнике соревнований, а затем:
Для сохранения введенной информации нажмите кнопку «Сохранить».
Для сохранения введенной информации и изменения информации о другом участнике соревнований нажмите кнопку «Следующий», после чего откроется новое диалоговое окно редактирования участника.
Для выхода из диалогового окна без сохранения измененных данных об участнике, нажмите кнопку «Выйти».

Удаление информации обо всех участниках соревнований

Удаление информации обо всех участниках соревнований по определенной дистанции осуществляется следующим образом:

На панели инструментов выберете дистанцию, для которой необходимо все участников и нажмите кнопку «Удаление базы данных».
В появившемся диалоговом окне нажмите кнопку “Yes” для удаления всех участников или “No” для отмены процесса удаления.

Ввод результатов соревнований

Ввод информации о результате выступления участника соревнований осуществляется следующим образом:

В меню Дистанции выберите дистанцию, для которой необходимо ввести результаты участника соревнований, далее в подменю «Ввод информации» выберите пункт «Результаты».
или
На панели инструментов выберете дистанцию, для которой необходимо ввести результаты участника соревнований и нажмите кнопку «Ввод результатов соревнования».
В появившемся диалоговом окне введите стартовый номер участника и нажмите кнопку “Enter”, после чего, если участник с таким номером существует, слева от поля ввода стартового номера отобразиться его ФИО, иначе появится сообщение о том, что участника с таким номером нет в базе данных. Далее, введите результат участника, а затем:
Для сохранения введенной информации нажмите кнопку «Сохранить».
Для сохранения введенной информации и изменения информации о другом участнике соревнований нажмите кнопку «Следующий», после чего откроется новое диалоговое окно ввода результатов.
Для выхода из диалогового окна без сохранения измененных данных о результате соревнования, нажмите кнопку «Выйти».


Формирование протоколов

В процессе работы программы автоматически формируются следующие документы для каждой дистанции в зависимости от пола участников:

Стартовые протоколы.
Финишные протоколы.
Наградные листы.
Стартовые протоколы формируются после добавления информации обо всех участниках (подробное описание см. в разделе Добавление нового участника соревнований) путем отображения стартового протокола по каждой дистанции в виде таблицы на экране либо с помощью пункта «Дистанции — Вывод информации — Стартовый протокол», либо с помощью контекстного меню, как показано на рисунке:

Финишные протоколы формируются только после формирования стартовых протоколов и внесения результатов соревнований (подробное описание см. в разделе Ввод результатов соревнований) путем отображения финишного протокола по каждой дистанции в виде таблицы на экране либо с помощью пункта «Дистанции — Вывод информации — Финишный протокол», либо с помощью контекстного меню, как показано на рисунке:

Наградные листы формируются по каждой дистанции, полу участника и каждой возрастной группе только после формирования финишных протоколов путем отображения наградного листа по каждой дистанции в виде таблицы на экране либо с помощью пункта «Дистанции — Вывод информации — Наградной лист», либо с помощью контекстного меню, как показано на рисунке:

При этом для контроля правильности ввода всех предыдущих данных при отображении наградного листа предусмотрена «Проверка информации по призерам» по имеющейся базе данных.


Проверка информации по призерам

С целью уменьшения возможных ошибок при вводе информации об участниках в программе предусмотрена проверка данных по призерам (отдельно по дистанциям, участникам и возрастным группам) на основании имеющейся базы данных для разных лет проведения соревнований.

Для проведения проверки необходимо вывести на экран «Наградной лист» (для конкретного года и участников) и нажать кнопку «Проверка данных». После подтверждения ваших действий (открывается промежуточное окно с вопросом) начнется процесс поиска по имеющейся базе данных. Во время поиска периодически появляется/исчезает надпись «Идет проверка данных», а ход поиска отображается с помощью индикатора.
Внимание! В зависимости от размера базы данных поиск может занять продолжительное время.

В случае, если данные по призерам совпадают с данными за все предыдущие годы (из существующих в базе данных) или если информация об участнике отсутствует в базе данных, над таблицей появляется надпись «Отличий в данных для призеров по имеющейся базе данных не обнаружено!» (зеленого цвета), а сама таблица остается незаполненной.

В случае найденных различий формируется таблица, в которую выводится информация об участниках-призерах по всем имеющимся годам, для которых найдены несоответствия. При этом можно воспользоваться функцией предварительного просмотра и (или) распечатать полученный результат, для этого в нижней части окна появится группа элементов «Вывод на печать», их назначение аналогично назначению элементов «Вывод на печать» в таблицах просмотра базы данных.

 




 
 
EDS-Soft

© 2002-2020 | EDS-Soft
Контакты | Правовая информация | Поиск | Карта сайта

© дизайн сайта | Андрей Азаров